刚学会Prim, 这几天都在撸最小生成树,撸着撸着撸到了一个interesting的题目:
http://poj.org/problem?id=2377
Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 12581 Accepted: 5222 Description
Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.
Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.Sample Input
5 8 1 2 3 1 3 7 2 3 10 2 4 4 2 5 8 3 4 6 3 5 2 4 5 17Sample Output
42Hint
OUTPUT DETAILS:
The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
Source
#include<cstdio>
#include<iostream>
#include<algorithm>
#define INF -1
int n,m;
int g[1001][1001];
int mc[1001];
bool used[1000];
using namespace std;
void solve(){
int res=0;
int cnt=0;
while(1){
int v;
v=-1;
for (int i=0;i<n;i++){
if (!used[i]&&(v==-1||mc[i]>mc[v])) v=i;
// cout<<v<<endl;
} // cout<<cnt<<' '<<n<<' '<<v<<' '<<mc[v]<<endl;
if (v==-1||mc[v]==INF) break;
cnt++; used[v]=1;
res+=mc[v];
// cout<<res<<endl;
for (int i=0;i<n;i++)
if(!used[i]) mc[i]=max(mc[i],g[v][i]);
}
printf("%d",(cnt==n)?res:-1);
}
void init(){
scanf("%d%d",&n,&m);
for (int i=0;i<n;i++){
mc[i]=INF;
used[i]=0;
for (int j=0;j<n;j++) g[i][j]=INF;
}
for (int j=0;j<m;j++){
int a,b,c;
scanf("%d %d %d",&a,&b,&c);
a--;
b--;
g[a][b]=g[b][a]=max(g[a][b],c);
}
mc[0]=0;}
int main(){
init();
solve();
return 0;
}
Comments
(Participate in the discussion)
Comments
No comments found.
No comments found.