今天中午,我终于把准备了一个星期的这道题AC了!

 

美中不足的是,由于没有删掉freopen,我TM贡献了一次WA...

所以,我们应该要做到吾日N省吾程序:

数组够大乎?

头文件没有错误乎?

freopen删掉乎?

...

先让我小小地得瑟一下,毕竟一直都很想A掉这题,为了这题,我学习了并查集,Kruskal,map(大雾),然后终于把这道题AC掉了,这告诉我们,做一道题也是能学到很多东西的...

Slim Span
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7242 Accepted: 3841

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge eE has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.


Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1
am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ mn(n − 1)/2. ak andbk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight ofek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

Source

题目大致上是要你找到一棵最“苗条”的生成树,就是这个生成树里最大边和最小边的差值要最小(话说这应该叫做最均匀生成树吧= =)
思路:
不要被数据范围吓到!看看时限,5000ms(其实即使1000ms也应该是能AC的,不会TLE),我的思路就是枚举每条边作为最小边然后进行Kruskal,最后选择Min{Max - Min}即可~
代码如下:

Source Code

Problem:3522 User:aclolicon
Memory: 784K Time: 297MS
Language: G++ Result:Accepted
    • Source Code
#include<cstdio>
#include<iostream>
#include<algorithm>
#define INF 0x77ffffff
using namespace std;
struct edge{
	int x, y, v;
}e[10005];
int ecnt;
int f[105];
int n, m, k;
bool cmp(edge x, edge y){
	return x.v < y.v;
}
int find(int x){
	if (f[x] != x) f[x] = find(f[x]);
	return f[x];
}
void restore(){
	for (int i = 0; i < 105; i++){
		f[i] = i;
	}
}
void solve(){
	sort(e,e+m,cmp);
//	cout << e[4].v << endl;
	int slim = INF;
	for (int mj = 0; mj < m; mj++){
		int cnt = 0;
		int minv = INF, maxv = -1;
		minv = e[mj].v;
		for (int i = mj; i < m; i++){
			int a = e[i].x, b = e[i].y, c = e[i].v;
			int x = find(a), y = find(b);
//			cout << "cmp" << (int)(x == y) << ':' << a << ':' << b << ':' << x << ':' << y << endl;
			if (x == y) continue;

			f[x] = y;
			cnt++;
//			cout << i << endl;
			maxv = c;
			if (cnt == n-1) break;
		}
//		cout << cnt << 'd' << endl;
		restore();
		if (cnt != n-1) continue;
		slim = min(slim, maxv - minv);
//		cout << slim << ':' << minv << ',' << maxv << endl; 

	}
	if (slim == INF){
		cout << -1 << endl;
		return;
	}
	cout << slim << endl;
}

void init(){
	restore();
	ecnt = -1;
	int x, y, z;
	for (int i = 0; i < m; i++){
		ecnt++;
		cin >> x >> y >> z;
		e[ecnt].x = x;
		e[ecnt].y = y;
		e[ecnt].v = z;
	}
	solve();
}
int main(){
//	freopen("c.in","r",stdin);
	while(1){
		cin >> n >> m;
		if (n == 0 && n == 0) return 0;
		init();
	}
}

那么我就继续向下一题发起进攻了!