不好意思最近在弄新网站没怎么做题了..大家可以去看看,(有福利喔)今天A一道

食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58997 Accepted: 17253

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

Source

NOI的好题啊..手都抖了,没想到好法子,百度了一下找到了一条好思路,写了一条程序(在手机上,因为学校体艺节= =),AC之。

Source Code

Problem: 1182 User: aclolicon
Memory: 920K Time: 282MS
Language: G++ Result: Accepted
    • Source Code
#include<cstdio>
//#include<iostream>
#define MAXN 50010
//using namespace std;
int f[MAXN * 3], n, k;

int find(int x){
	if (f[x] != x) f[x] = find(f[x]);
	return f[x];
	}
bool same(int x, int y){
//	cout << "get same " << x << " and " << y;
	x = find(x);
	y = find(y);
//	cout << " get x " << x << " y " << y << endl;   
	return x == y;
	}
void comb(int x, int y){
	x = find(x);
	y = find(y);
	if (x != y) f[x] = y;
	return;
	}
void init(){
	scanf("%d%d", &n, &k);
	for (int i = 0; i < n * 3 + 1; i++)
	f[i] = i;
	int x, y, z, ans = 0;
	for (int i = 0; i < k; i++){
		scanf("%d%d%d", &z, &x, &y);
		x--;
		y--;
		if (x < 0 || y < 0 || x >= n || y >= n) {
//			cout << i << "," << z << endl; 
			ans++;
			continue;
			}
		if (z == 1){
			if (same(x, y + n) || same(x, y + n * 2)){
//				cout << i << "," << z << endl; 
				ans++;
				continue;
				}
			comb(x, y);
			comb(x + n, y + n);
			comb(x + n * 2, y + n * 2);
			}else{
				if (same(x, y) || same(x, y + n * 2)){
//					cout << i << "," << z << endl; 
					ans++;
					continue;
					}
				comb(x, y + n);
				comb(x + n, y + n * 2);
				comb(x + n * 2, y);
				}
				
		}
		printf("%d",ans);
	}
void solve(){
	}
int main(){
//	freopen("c.in", "r", stdin);
	init();
	return 0;
	}