期末完了,做POJ,很水的题就不说了,来说一道比较水的题。

Dividing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 67526 Accepted: 17570

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

题意。
有许多价值分别为1-6的石头,求是否能分成价值相等的两堆,总价值不会超过20000。
做法。
看见很多人用DFS,但由于我是蒻蒟,只好用母函数。
(1 + x + x^2 + ...) * (1 + x^2 + x^4 + ...) * (1 + x^3 + x^6 + ...) * (1 + x^4 + x^8 + ...) * (1 + x^5 + x^10 + ...) * (1 + x^6 + x^12 + ...)
展开,得x^(totalV/2)的系数,判断是否为0即可。
母函数百度一堆教程,这里不说了。
不过有一个莫名其妙的优化搞不懂,我也不好说。上代码。

[code lang="cpp"]/*Source Code

Problem: 1014 User: aclolicon
Memory: 400K Time: 0MS
Language: G++ Result: Accepted
Source Code
*/
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
// freopen("c.out", "w", stdout);
int m[7];
int x[256], y[256];
int n = 0;
while(++n){
int t;
int v = 0;
for (int i = 1; i <= 6; i++) {
scanf("%d", &t);
if (t > 8) t = (t % 2 == 0? 12: 11);//???
m[i] = t;
v += t * i;
}
if (v == 0) break;
if (v % 2 != 0){
printf("Collection #%d:\nCan't be divided.\n\n", n);
continue;
}
memset(x, 0, sizeof(x));
memset(y, 0, sizeof(y));
x[0] = 1;
v /= 2;
for (int i = 1; i <= 6; i++){
for (int j = 0; j <= v; j++)
for(int k = 0; k <= m[i] && k * i + j <= v; k++)
y[k * i + j] += x[j];
memcpy(x, y, sizeof(y));
memset(y, 0, sizeof(y));
}
if (x[v] == 0) printf("Collection #%d:\nCan't be divided.\n\n", n);
else printf("Collection #%d:\nCan be divided.\n\n", n);
}
return 0;
}
[/code]
毕竟我还只是个蒻蒟,有纰漏不要打我。